DDS.NL Basispakket ADSL Producten Login Helpdesk
Helpdesk Contact Instellingen Aanmelden

 

PHP 7 Upgrade

Op 2 Juli 2018 is DDS overgegaan van PHP 5.6 naar versie 7.2

Deze upgrade hebben we uitgevoerd om ervoor te zorgen dat we ook in de toekomst de meest recente web applicaties kunnen hosten.

PHP 5.6 is per 31 Dec 2018 EOL (end of life) qua beveiliging- updates, vandaar dat we ook bijtijds over wilden naar PHP 7.2

Een van de grootste veranderingen aan PHP 7.x is het afschaffen van de mysql extentie. Sites die een connectie met de mysql server willen maken zullen onder PHP 7.x de Mysqli extentie moeten gebruiken.

Moderne webapplicaties zoals Wordpress en Joomla gebruiken al jaren Mysqli en zullen van deze upgrade verder geen last hebben.

Zelf geschreven scripts (of verouderde applicaties) zullen echter wel bijgewerkt moeten worden om te kunnen werken onder PHP7.

We verzoeken je je site 'php7 ready' te maken. Hoe je dit kan doen kan je lezen via de links hieronder.

Moet jouw web applicatie echt per-se op 5.x blijven draaien? Dan is het eventueel mogelijk om je site te migreren naar een zuster bedrijf die wel wat langer php 5.x support gaat bieden.

Mocht je nog vragen hebben, neem gerust even contact op met onze helpdesk: helpdesk@dds.nl of 085 - 747 07 07

Relevante links:

Migratie gids van 5.6.x naar 7.x:
http://php.net/manual/en/migration70.php

7.0 Incompatible functies:
https://secure.php.net/manual/en/migration70.incompatible.php

7.1 Incompatible functies:
https://secure.php.net/manual/en/migration71.incompatible.php

7.2 Incompatible funcies:
https://secure.php.net/manual/en/migration72.incompatible.php

PHP Lifecycle:
http://php.net/supported-versions.php


 

Alle prijzen inclusief 21% btw, algemene voorwaarden, contact, rechten DDS©